2007 corsa d sxi 1.2 16v

User Tag List

Results 1 to 2 of 2

Thread: 2007 corsa d sxi 1.2 16v

  1. #1

    Join Date
    20-05-2018
    Location
    Shrivenham (Oxfordshire)
    Posts
    6

    2007 corsa d sxi 1.2 16v

    Hi, so Basically my car is fooked and i need help diagnosing whats wrong with it.

    1) I have the mayo build up under the oil cap, loosing about half an inch of coolant every few weeks, Blown Head gasket? (Please no) I know you can get this mayo build up from short journeys and i do drive max 7 miles per journey, but i can't see any obvious coolant leaks so yeah.

    2) I have had issues with emissions in my last MOT and put a bottle of Cat cleaner in the tank and just got it to pass. I have changed both Lambda sensors just to rule them out. I do get the sulphur/rotten egg smell when idling which leads me to believe the CAT is broken however i have been told that the cat may not be broke, it may be overfueling and therefore not being able to burn the sulphur in the fuel properly? Recently my fuel consumption has gone to pot maybe 200 miles per tank/250 at the most.

    I don't mind changing the CAT or doing the Head-gasket but before i do i just want to be 100% sure its definitely them as they are long jobs to do.

    MY EML light is on btw
    Last edited by PorkyJoshy; 09-02-2019 at 23:14.

  2. Remove Advertisements
    UKCorsa-D.com
    Advertisements
     

  3. #2

    Join Date
    01-12-2018
    Posts
    8
    Click here to enlarge Originally Posted by PorkyJoshy Click here to enlarge
    Hi, so Basically my car is fooked and i need help diagnosing whats wrong with it.

    1) I have the mayo build up under the oil cap, loosing about half an inch of coolant every few weeks, Blown Head gasket? (Please no) I know you can get this mayo build up from short journeys and i do drive max 7 miles per journey, but i can't see any obvious coolant leaks so yeah.

    2) I have had issues with emissions in my last MOT and put a bottle of Cat cleaner in the tank and just got it to pass. I have changed both Lambda sensors just to rule them out. I do get the sulphur/rotten egg smell when idling which leads me to believe the CAT is broken however i have been told that the cat may not be broke, it may be overfueling and therefore not being able to burn the sulphur in the fuel properly? Recently my fuel consumption has gone to pot maybe 200 miles per tank/250 at the most.

    I don't mind changing the CAT or doing the Head-gasket but before i do i just want to be 100% sure its definitely them as they are long jobs to do.

    MY EML light is on btw
    You may get the symptoms of a head gasket failure under the oil filler by doing short journeys but it won't use coolant.

    Look, if it's grey, looks like an elephant, smells like an elephant and ****s like an elephant, looking up grey mammal on Google doesn't mean it's a mouse.

    Get it tested properly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Corsa D 2007 1.4sxi 16v - Engine questions
      By Nikkipole in forum Mechanical
      Replies: 3
      Last Post: 10-01-2013, 11:46
    2. My Corsa D SXi 1.2 16v
      By Macca_Boi in forum Your Corsa D
      Replies: 9
      Last Post: 11-03-2008, 00:42

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •