Corsa 1.3 ctdi help!!

User Tag List

Results 1 to 2 of 2

Thread: Corsa 1.3 ctdi help!!

  1. #1

    Join Date
    18-11-2015
    Age
    44
    Posts
    2

    Corsa 1.3 ctdi help!!

    Hey all,looking for an opinion on an issue with my corsa.an INSP4 warning popped up,which I googled to find an issue with the fuel filter, so I booked it in for a service with full filter changes.the moment I picked it back up,it took 3 tinea to start, then the following week,it started but couldn't get it above 2000 revs and ended getting AA'd to said garage.they told me that the fuel looked contaminated and could not find any other issues.ive whacked 4 tanks of premium diesel through it and it's still a bag of crap,under powered and struggles at low speed.and ideas of what could be the problem?would the EGR need doing again(last done 3 years ago)or maybe faulty filter?need help!!!!thanks all.

  2. Remove Advertisements
    UKCorsa-D.com
    Advertisements
     

  3. #2

    Join Date
    02-10-2014
    Location
    Kent
    Posts
    130
    Click here to enlarge Originally Posted by ivorbiggunn Click here to enlarge
    Hey all,looking for an opinion on an issue with my corsa.an INSP4 warning popped up,which I googled to find an issue with the fuel filter, so I booked it in for a service with full filter changes.the moment I picked it back up,it took 3 tinea to start, then the following week,it started but couldn't get it above 2000 revs and ended getting AA'd to said garage.they told me that the fuel looked contaminated and could not find any other issues.ive whacked 4 tanks of premium diesel through it and it's still a bag of crap,under powered and struggles at low speed.and ideas of what could be the problem?would the EGR need doing again(last done 3 years ago)or maybe faulty filter?need help!!!!thanks all.

    Disconnect to battery for 30 minutes to reset the ECU, this has happened to mine before and this sorted it. Might work, might not.

    If it struggled to start after they changed the filter I bet they didn't prime the new filter properly and got air in the system, try priming it, turn the key on 2 clicks, wait for the fuel pump to stop whining up then turn off, repeat a few times then start. if it starts try and see if it goes past 2000rpm, if it does give it an Italian tune up by revving to 4000rpm and few times, this might clear out the trapped air, can't see it being contaminated fuel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •