Possible Overheating? - What's the cause?

User Tag List

Results 1 to 11 of 11

Thread: Possible Overheating? - What's the cause?

  1. #1

    Join Date
    06-06-2017
    Posts
    291

    Possible Overheating? - What's the cause?

    Hey guys. Needing some help as scratching head a bit. Have a 1.2 Corsa D SXI 2013. Bit of a weird one so stay with me.

    When I'm driving I have the hidden temperature gauge on my Dash to show coolant temp. As I'm driving the car will steadily rise to 109c at which point the fan will kick in and cool engine back down to 100c. I continue driving and the cycle repeats, if heater is put on hot max I can get temp down to about 95c. I have noticed and done a few things:

    1) I noticed on my wiring that goes to the coolant temp sensor on the radiator, The wire was frayed and showing some copper strands and I had to 'Re tape that up.

    2) On my bleeder screw located on top of the radiator it is weeping some coolant.

    3) I recent (in August) changed the water pump and then also changed the thermostat (with OEM and thermostat was just for preventative maintenance). Before fitting thermostat I tested my old OEM stat and the new OEM stat in boiling water and neither of them opened up. I assumed it was because in my Haynes manual is says operating temp is 103c and boiling water is about 100c. So simply wasn't hot enough to open. I have noticed then when my dash is saying 107-108c the lower rad hose that the thermostat is connected to, the hose is still cold to the touch but the upper rad hose is hot approx 97 - 100c. Which I would have thought the hose should be hot as to let coolant into the rad to be cooled

    So my issue is, do I have 3 separate problems or is one problem causing a domino effect? Weeping bleeder causing airlock ? Frayed wiring causing coolant temp sensor to read wrong and cause over heating. Is my new thermostat faulty (ps I contacted the company I bought OEM stat from and they said: "hi this will not open until 109 so when fitted did you do this as we have to put on tech 2 to watch the temperature and we don 't let the vehicle go until we see the thermostat open this will be a fitting issue, not the part kind regards steve" is 109c when the thermostat opens up at the same time as the fan kicking in?

    Any ideas would be great. Thanks

    Sent from my SM-G935F using Tapatalk

    Sent from my SM-G935F using Tapatalk

  2. Remove Advertisements
    UKCorsa-D.com
    Advertisements
     

  3. #2

    Join Date
    04-01-2016
    Location
    Norwich/Great Yarmouth
    Age
    36
    Posts
    190
    The temp sensor on the radiator, the wiring plug sometimes has to be replaced.

  4. #3

    Join Date
    06-06-2017
    Posts
    291
    Click here to enlarge Originally Posted by corsa sri ant Click here to enlarge
    The temp sensor on the radiator, the wiring plug sometimes has to be replaced.
    Thanks for this Ant. I have ordered a n3w kit and plan to splice it in. Just worst weather to be doing this lol.

    Sent from my SM-G935F using Tapatalk

  5. Remove Advertisements
    UKCorsa-D.com
    Advertisements
     

  6. #4

    Join Date
    06-06-2017
    Posts
    291
    Click here to enlarge Originally Posted by corsa sri ant Click here to enlarge
    The temp sensor on the radiator, the wiring plug sometimes has to be replaced.
    Hey Ant can check something with you. I.got my new connector wiring today. Firstly is this correct for the radiator temp sensor and secondly is it a matter of just push the wires into the holes??

    Thanks pal.

    Sent from my SM-G935F using Tapatalk

  7. #5

    Join Date
    04-01-2016
    Location
    Norwich/Great Yarmouth
    Age
    36
    Posts
    190
    Click here to enlarge Originally Posted by everson38 Click here to enlarge
    Hey Ant can check something with you. I.got my new connector wiring today. Firstly is this correct for the radiator temp sensor and secondly is it a matter of just push the wires into the holes??

    Thanks pal.

    Sent from my SM-G935F using Tapatalk
    Have you got a picture?

  8. #6

    Join Date
    06-06-2017
    Posts
    291
    Click here to enlarge Originally Posted by corsa sri ant Click here to enlarge
    Have you got a picture?
    Thanks mate. I thought I uploaded a pic. But here you go.Click here to enlarge

    Sent from my SM-G935F using Tapatalk

  9. #7

    Join Date
    04-01-2016
    Location
    Norwich/Great Yarmouth
    Age
    36
    Posts
    190
    93188697 is the correct kit, I'd also recommend changing the sensor, part number 55591002. The old wiring plug has to be cut off and the new plug connected with connectors and heat shrink.

  10. #8

    Join Date
    06-06-2017
    Posts
    291
    Click here to enlarge Originally Posted by corsa sri ant Click here to enlarge
    93188697 is the correct kit, I'd also recommend changing the sensor, part number 55591002. The old wiring plug has to be cut off and the new plug connected with connectors and heat shrink.
    Thanks for that. I more wanted to know do you simply push the yellow/ silver ends into the connector head. I don't need no special tool or special way to lock them into place into the connector head. ? Thanks

    Sent from my SM-G935F using Tapatalk

  11. #9

    Join Date
    04-01-2016
    Location
    Norwich/Great Yarmouth
    Age
    36
    Posts
    190
    Click here to enlarge Originally Posted by everson38 Click here to enlarge
    Thanks for that. I more wanted to know do you simply push the yellow/ silver ends into the connector head. I don't need no special tool or special way to lock them into place into the connector head. ? Thanks

    Sent from my SM-G935F using Tapatalk
    I've just checked with technician, he said they just push into plug.

  12. #10

    Join Date
    06-06-2017
    Posts
    291
    Click here to enlarge Originally Posted by corsa sri ant Click here to enlarge
    I've just checked with technician, he said they just push into plug.
    Absolute legend mate. Thanks for doing that for me.

    Sent from my SM-G935F using Tapatalk

  13. #11

    Join Date
    04-01-2016
    Location
    Norwich/Great Yarmouth
    Age
    36
    Posts
    190
    Click here to enlarge Originally Posted by everson38 Click here to enlarge
    Absolute legend mate. Thanks for doing that for me.

    Sent from my SM-G935F using Tapatalk
    No worries, always happy to help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •