Vauxhall Corsa-D Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
251 Posts
Discussion Starter #1
Hi

I was teaching one of my mates how to drive earlier and noticed the yellow car with the spanner light had come on randomly.
I then drove the car and felt a lack of power. I pulled over, turned the engine on then off and then the car went back to normal.
Is there anything to worry about or shall I just leave it? I've only had the car for 6months now with 30,000 on the clock and I still have 6months warranty.

Thanks.
 

·
Registered
Joined
·
251 Posts
Discussion Starter #4
did it go into limp mode and struggle to rev?
It went limp but I still managed to rev it slightly. It just felt like the turbo had gone as there was no kick.

Take it back to vx if you still have warranty, may need a service or an oil change depending on mileage and how you drive
I bought it from a Honda garage in September and the warranty is with Honda, where it just had been MOT'd and serviced. I've put nearly 6K on the clock already.
 

·
Registered
Joined
·
635 Posts
When the light came on mine and i had the similar symptoms to yourself it turned out to be my coilpack that had broke.
 

·
Registered
Joined
·
32 Posts
I get an oil change every 6k although I think 10k is the recommended time to change. Mine just feels sluggish around 5 or 6k so yours may be the same buddy
 

·
Registered
Joined
·
27 Posts
You really need a fault reader, my 57 had same problem, plugged it in founded I needed a new throttle pedal, got 1 from eBay for 50 quid fitted reset the computer job done
 
1 - 11 of 11 Posts
Top