Vauxhall Corsa-D Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Looking for some help with a couple of issues on my 2014 Corsa 1.3cdti

I noticed on the drive home from work last night that I couldn't get the cruise control to work, had a quick look online and looks like it could be a number of things, faulty stalk, switch at brake or clutch etc hadn't had a chance to have a better look but on my journey into work this morning when cruising at steady speed in 5th gear on the motorway I kept seeing the "shift" light, it would disappear under acceleration but would reappear when cruising, only problem is that I don't another gear to "shift" into.

Is it possible that these two issues are related?
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,137 Posts
Sounds as if you’re barking up the right tree on that, a code read from somewhere that has opcom/tech 2 would tell you more, given it has been working and isn’t now along with the shift up light says to me that the clutch switch is partly to blame.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Thanks, just been out to the car and noticed that I can start the car without my foot on the clutch, is this normal?
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,137 Posts
Tbh I’ve just got into the habit of foot on clutch when I’m starting anything but I’ve been driving since I was 13 (farming) so after 31 years it’s instinct now but I’ll check when I leave work!
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,137 Posts
Well my friend, it starts with and without clutch pedal pressed so that’s possibly not the answer, still think it needs a code reader
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Well my friend, it starts with and without clutch pedal pressed so that’s possibly not the answer, still think it needs a code reader
Thanks for checking for me, I wasn’t sure if it could be started without depressing the clutch as like you I always do it out of habit!

Weirdly enough on the drive home last night my cruise control was working and the shift like was working properly.
 
1 - 6 of 6 Posts
Top