Vauxhall Corsa-D Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hi all,

After a bit of expertise on behalf of my sister's 2008 Corsa 1.4 Club Auto please. A few months back it suffered loss of power steering and dashboard lights etc which turned out to be a dead alternator. I replaced the alternator and this restored a 14.6V charging voltage. The battery light on the dash stayed on and the car went flat overnight despite a full battery charge. So I replaced the battery because it looked like the original, was quite old and I suspected the alternator issue may have finished it off. Once this was done the dash battery light went off. I thought this was the end of the issues but then the battery kept going flat when left more than a day without being driven. I have replaced the alternator again in case of a diode issue and replaced the battery again just in case but the car continues to go flat every 36-48 hours.

I carried out a battery drain test and intermittently saw 130-150mA appearing but this would drop back to an acceptable 20mA sporadically. Having given up and taken the car to a local auto electrician, all they were able to do without running up a big bill is confirm that it's an intermittent high drain as per what I'd seen myself.
I've repeated the drain test waiting until the current draw appears and then pulling fuses and have been through all 3 fuse boxes (engine, glovebox and boot) and the only fuse that kills the drain is the central control unit at 70A. Bearing in mind this is the brains of the car I'm not sure what to do next. Tried a temporary fix of a solar trickle charger but it seems it's not sufficient to keep the battery voltage high enough.

Any suggestions would be very much appreciated as I'm losing patience with it now but don't want to be defeated!!!
 

·
Registered
Joined
·
516 Posts

·
Registered
Joined
·
3 Posts
Hi,
I have a corsa D 09 automatic, I have had intermittent battery drain problem. It’s fine for a week then battery goes flat over night, had 3 garages look at it, battery and alternator fine as fitted new when last time had problem. Didn’t resolve the issue still kept waking up to dead battery. Car will boost back to life or jump start, garages said their must be parasitic drain on battery, so had auto electrician look at, but on the day he came, the car worked fine. He still did some checks and said everything was fine, he noticed lights took while to kick in, but not sure what he meant as I wasn’t ere and wife felt with him, he said all leads from battery okay and maybe it could be to do with the gear box and to dead lock the car every time. Which we been doing and worked fine for 10 days no problems starting every day, wife came to start car today late in afternoon and nothing dead again, car jumped okay and works when started no dull lights etc, starts everytime when key is turned off and on, can anyone shed any light if they have had this problem and how they fixed it as it’s driving me insane and I just want put a match to it at this point
 

·
Registered
Joined
·
1 Posts
Hi,
I have a corsa D 09 automatic, I have had intermittent battery drain problem. It’s fine for a week then battery goes flat over night, had 3 garages look at it, battery and alternator fine as fitted new when last time had problem. Didn’t resolve the issue still kept waking up to dead battery. Car will boost back to life or jump start, garages said their must be parasitic drain on battery, so had auto electrician look at, but on the day he came, the car worked fine. He still did some checks and said everything was fine, he noticed lights took while to kick in, but not sure what he meant as I wasn’t ere and wife felt with him, he said all leads from battery okay and maybe it could be to do with the gear box and to dead lock the car every time. Which we been doing and worked fine for 10 days no problems starting every day, wife came to start car today late in afternoon and nothing dead again, car jumped okay and works when started no dull lights etc, starts everytime when key is turned off and on, can anyone shed any light if they have had this problem and how they fixed it as it’s driving me insane and I just want put a match to it at this point
I have exactly the same problem on my 07 corsa and it’s driving me mad. Garages can’t find a problem. Have you solved it yet?
 

·
Registered
Joined
·
3 Posts
I have exactly the same problem on my 07 corsa and it’s driving me mad. Garages can’t find a problem. Have you solved it yet?
I did fix this problem with mine, I installed the wrong size battery put 45 not a 54 on, and way wife was using it for work wasn’t helping the problem. Very short journey. We installing solar charge to keep it topped up on days she not using it.
That’s why no1 could find a problem as battery was okay etc, and they couldn’t find the drain either.
I hope this helps as it drove us mad for 4 weeks or more
 
1 - 5 of 5 Posts
Top