Vauxhall Corsa-D Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
268 Posts
Discussion Starter · #1 ·
Posted something similar to this before.. its just gotten worse now!

Motor works on all speeds, Sometimes won't do naff all though stops working when i hit speedbumps etc and makes a horrid grinding noise. Takes a good whack on the bottom to get her moving again.. Do you just think its the motor? Got one for 63 quid on way now but do u think ill need a resistor or harness too?
 

·
Registered
Joined
·
65 Posts
have u taken the glove box out and checked the plug for the fan and also taken the fan out its casing and giving it a good clean

theres a tutorial telling u how to do it somewhere


Sent from my iPad using Tapatalk HD
 

·
Registered
Joined
·
3,127 Posts
Cleaning it doesn't tend to prolong the life once it starts going, believe me l've tried. Best just changing the fan tbh.
 

·
Registered
Joined
·
268 Posts
Discussion Starter · #4 ·
Nah i think its as good as cream crackered tbh! I will remove it now though and take a quick gander to see if theres anything jamming it before unboxing my new one and replacing it
 

·
Registered
Joined
·
268 Posts
Discussion Starter · #5 ·
Tried to fix old unit plugged it in turned it on still a fault but when it got to speed 4 it caused some really bad smoke and electrical popping. Gona bin that. Couldnt of caused much damage right?
 

·
Registered
Joined
·
268 Posts
Discussion Starter · #7 ·
Knocked that one on head, Removed it and left it in bits for now. Will fit new one when i have some time :)
 
1 - 7 of 7 Posts
Top