Vauxhall Corsa-D Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My car has gone into limp mode. I can only assume it is due to, what I believe, is the brake booster vacuum hose? I think the hose may be OK but there's a plastic bit snapped inside the hose itself and where it connects into the engine/manifold/not to sure what it is! I've attached pictures, would really appreciate if someone could help me out on how to proceed or whether it is time to take it into a garage? Thanks in advance
 

Attachments

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,404 Posts
Garage job mate, unless you’re reasonable with the spanners then have a go yourself but with it being possibly brake related I’d get it trailered to a garage for repair
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Well the car was in limp mode and very smokey (very!) Took to the garage and he's managed to get a bit of metal pipe and attach it between the vacuum servo hose and manifold and car seems to be great, not smokey and not in limp mode. He did suggest turbo was probably on the way out if it was smokey, but the car is running really smooth now so not sure whether to keep the car or sell if it is the turbo. Anyone got any recommendations?
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,404 Posts
Hope it isn’t the turbo on its way out but if it’s not smoking and running ok then you may have just dodged a bullet, just keep an eye out for another motor, just in case!!
 
1 - 7 of 7 Posts
Top