Vauxhall Corsa-D Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter #3
I've got a buggered JL 300/2 somewhere that faulty. Not sure whats wrong with it though, it's a US model amp s couldn't get it fixed under warrenty in the UK.
whoooop.

What was wrong with? You tried opening it up mate?

How much would you sell it for? Ive brought an amp repair manual, and wana try it out. Although i was kinda hoping my first project would be a naff amp, not a £500 JL Audio jobby lol


Martin
 

·
Owner & Administrator
Joined
·
1,143 Posts
Obviously cost me hundreds new but it's no use to be now as I bought another new 300/2 now so not expecting much back, if anything for it as its 2nd hand and buggered just think it will cost a bit to post as it is heavy lol.

Not tried opening it up as I wouldn't know where to start mate! Could a wire problem or circuit board or something else got no ideas?! It just kept over heating and cutting out.

Si
 

·
Registered
Joined
·
170 Posts
Discussion Starter #5
I'm not sure to be honest mate, ive never worked on one before - this could be my first!

If its over heating and cutting out, maybe its something as simple a a PCD braking away from the heat sink? Or even the part that detects temperature could be faulty... :shrug:

hopefully once its been opened and a few areas have been tested the problem should show its sef
 

·
Registered
Joined
·
62 Posts
I've got a cheap amp that's f00ked, opened it up and almost all the fuse wire inside has broke (burnt out) and a few resistors, a friend was going to re solder it, but never got round to it and don't know what resistors it requires.

it's ment to be a 1600w amp no idea on make just has a few numbers on it starting XHT-????
 
1 - 7 of 7 Posts
Top