Vauxhall Corsa-D Forum banner

1 - 20 of 36 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hey guys, i need some advice,

I have a corsa d 2008 1.3 cdti, it was not heating up inside the car and coolant was dissapearing, so flushed the system, and changed the stat. Now with the new thermostat it reaches only max 75 degrees, and when it dose alot of steam comes from the radiator, as well as coolant dissapearing.

I believe it to be the radiator now as i believe collant somehow is coming out of the radiator and burning from the heat of the rad.

Any suggestions?
 

·
Registered
Joined
·
288 Posts
hi yes if the coolant level is dropping there has to be a leak somewhere.are all the hoses warming up properly ?
is there coolant on the floor ?check the unions in the hoses and the radiator is a place to look if its old.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Yea i agree theres a leak, but the only coolant/water i see is on the rear of the radiator fan, other then that non on the floor...ive even run the engine for 30mon and been under the car and see no leaks, however when i go for a drive and come back theres water appearing on the rad...i assumed it was because water was coming out the overflow pipe, however ive changed the expansion tank cap, and still no preassure, coolant leak, and no warm air?

im dreading it be a gasket issue but i have got all the other tell tell signs
 

·
Registered
Joined
·
288 Posts
always think of the obvious common faults first before worrying about the head gasket leaks.are competent DIY person ?if so it's worthwhile looking at the hoses and unions thoroughly or maybe a corroded radiator itself.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
always think of the obvious common faults first before worrying about the head gasket leaks.are competent DIY person ?if so it's worthwhile looking at the hoses and unions thoroughly or maybe a corroded radiator itself.
Yes definitely.

yea im pretty handy with car mechanics to an extent, ive check the hoses a few times, i think its tome for a pressure test....possibly radiator as it looks knackered.
 

·
Registered
Joined
·
657 Posts
Yeah I wouldnt jump to the head yet. You said you see steam coming from the radiator. Start there. For more viewongni would remove the from bumper and then run you car again and see for leaks. Missed spot aswell is check the bleed screw on the very top of the radiator to the left when facing your car.

Sent from my moto g(8) plus using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Yeah I wouldnt jump to the head yet. You said you see steam coming from the radiator. Start there. For more viewongni would remove the from bumper and then run you car again and see for leaks. Missed spot aswell is check the bleed screw on the very top of the radiator to the left when facing your car.

Sent from my moto g(8) plus using Tapatalk
Ohh i didnt realise theres another bleed screw other then the one on the bottom of the radiator. I will take a look at that.

yes i see steam/smoke from the radiator as if coolant has leaked onto it, that being said the car is struggling to get up to temp, or past 75....making me think its the head thats the issue..
 

·
Registered
Joined
·
657 Posts
Ohh i didnt realise theres another bleed screw other then the one on the bottom of the radiator. I will take a look at that.

yes i see steam/smoke from the radiator as if coolant has leaked onto it, that being said the car is struggling to get up to temp, or past 75....making me think its the head thats the issue..
Yes the bleed screw can be seen in the video. Some have it where the video shows and others have it just in the very top of radiator but still in the same area. There is a small whole in the top of your bumper to see this.

Again I wouldn't jump HG just yet, as you clearly have a problem with the rad, ideally I would just take the bumper off and record a video of what it is doing and upload to YouTube and put link here to let people see what the issue is properly doing. Wth the bumper off you can see so much more trust me, you will thank yourself once done, very easy to do.

Sent from my moto g(8) plus using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
Yes the bleed screw can be seen in the video. Some have it where the video shows and others have it just in the very top of radiator but still in the same area. There is a small whole in the top of your bumper to see this.

Again I wouldn't jump HG just yet, as you clearly have a problem with the rad, ideally I would just take the bumper off and record a video of what it is doing and upload to YouTube and put link here to let people see what the issue is properly doing. Wth the bumper off you can see so much more trust me, you will thank yourself once done, very easy to do.

Sent from my moto g(8) plus using Tapatalk
Ahhh i did not know that, if possible do you have a pic or vid of the bleed screw i need to look out for?
 

·
Registered
Joined
·
288 Posts
Yes the bleed screw can be seen in the video. Some have it where the video shows and others have it just in the very top of radiator but still in the same area. There is a small whole in the top of your bumper to see this.

Again I wouldn't jump HG just yet, as you clearly have a problem with the rad, ideally I would just take the bumper off and record a video of what it is doing and upload to YouTube and put link here to let people see what the issue is properly doing. Wth the bumper off you can see so much more trust me, you will thank yourself once done, very easy to do.

Sent from my moto g(8) plus using Tapatalk
true.i will have a look at the radiator first. i am sure its corroded and leaking.replacement with new rad will solve all your problems
 

·
Registered
Joined
·
657 Posts
Ahhh i did not know that, if possible do you have a pic or vid of the bleed screw i need to look out for?
I don't have a picture but here is a link to it, I'll try do a video for you tomo if I remember.

Sent from my moto g(8) plus using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #13
Yes the bleed screw can be seen in the video. Some have it where the video shows and others have it just in the very top of radiator but still in the same area. There is a small whole in the top of your bumper to see this.

Again I wouldn't jump HG just yet, as you clearly have a problem with the rad, ideally I would just take the bumper off and record a video of what it is doing and upload to YouTube and put link here to let people see what the issue is properly doing. Wth the bumper off you can see so much more trust me, you will thank yourself once done, very easy to do.

Sent from my moto g(8) plus using Tapatalk
Also with the fact im getting a low temp reader is this the reason why the fan never comes on? Because im worried to drive it now as the steam/smoke would indicate the car is overheating, but I'm also thinking that water is leaking onto the rad? So driving it would be fine aslong as i keep topping up the coolant? Such an annoying situation
 

·
Registered
Joined
·
15 Posts
Discussion Starter #15
I don't have a picture but here is a link to it, I'll try do a video for you tomo if I remember.

Sent from my moto g(8) plus using Tapatalk
You know what ive noticed also (im so daft) ive only been undoing the drain screw at the bottom? I didnt undo the bleed screw when i change the thermostat, could that also be an issue?
 

·
Registered
Joined
·
657 Posts
You know what ive noticed also (im so daft) ive only been undoing the drain screw at the bottom? I didnt undo the bleed screw when i change the thermostat, could that also be an issue?
You could have an air lock from not doing the bleed screw, but not sure how that will make steam come out the rad, I'm thinkin the rad has hole in it. The bottom drain plug is just for that to drain coolant, it wont bleed anything as it just let's coolant out.

Also watch this video about a Chevy Cruze, these are basically Corsa D in America, this shows the process also with bleeding


Sent from my moto g(8) plus using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #19
Only a tiny bit when starting from cold? But nothing more?

oil is perfect and black?
Im so annoyed i didn't notice water building up.
 

·
Registered
Joined
·
288 Posts
Then could it be a blocked heater matrix due to cold weather?can you get a second opinion from a mobile mechanic also?
 
1 - 20 of 36 Posts
Top