Vauxhall Corsa-D Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
First of all hello to all,

I drive Corsa D 1.3 diesel 55kw 2009

I recetly had faulty gearbox as the mechanical that changed my flywheel before forgot to put oil in gearbox so it died like on this picture, but that somehow happend not to be only problem.



While i was driving car like this with my new gearbox in trunk, my car suddenly turned off, i tried to start it but no success.
I changed gearbox, put the new one, car wont start again.
So we checked common rail system while bosch pump above is good, injectors are perfect, fuel pump in trunk is good, new battery tried aswell, checked every fuse, perfect, pressure sensor good(havent tried new pressure regulator sensor btw). they told me then that probably how to explain timing chain skipped over, so they have put it back in line, they checked camshaft and crankshaft, perfect, valves perfect, everything mechanical is perfect.

However we connected bosch computer for compression and pressure check.

So to start the car rail needs to have atleast 250+ bars to start car on mains fuel lead right ? my car somehow gets under 30bars and it wont start. The engine cranking seems to be fine and nothing unusual to hear, but it wont start.

But they never told me the erros i get on board computers
which are next:

P0180 - CNG temp sens voltage fail
P0683 - Glow plug ctrl mod to pcm comm circ
P0190 - Fuel Rail sens circ
P0335 - Crank pos sens circ
P0520 - Engine Oil Press sens/switch circ

Since i have no clue what those errors means neither does my mehanic guy does, i had to ask here.

I really need some help out since my car is 3 weeks at workshop with no success


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
25 Posts
Discussion Starter #2
i mean i know they are related to some sensor, so is there any chance to be crankshaft sensor ? could it be destroyed when gearbox failed? since it location is near Flywheel


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,185 Posts
I’ve seen a video on YouTube recently that sounds similar. Granted it was a petrol engine, but the car wouldn’t start. All he did was change the crank sensor, it started first time.


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
Top