Vauxhall Corsa-D Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello everyone, I have had my corsa since Dec 2019, it is on 63k miles and is a 2011 sxi 5dr. I have had the engine management light come on and it reads the p0420 code which is “catalyst system efficiency below threshold bank 1” I have also noticed that my fuel consumption has gone up. I usually fill up every 3/4 weeks but have filled up 3 times in July. Can some suggest what the issue could be? Could it be the oxygen sensor or is my cat bust. Please help me out! Thank you.
 

·
Premium Member
Joined
·
275 Posts
I’d be tempted to try the o2 sensor first as they have a habit of going loopy. Saying that it is said they’re a better quality from Vauxhall and the bigger motor factors as the cheap e bay ones aren’t the best quality and fail again soon after putting in. Think there’s been a thread on here saying the same.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Mechanics recommended cataclean and go on the motorway for 30/40 mins, but for some reason dont trust him as he couldnt identify the problem fully. He said “it could be oxygen sensors but if the codes for the cat, should be the cat” not sure what to do..
 

·
Premium Member
Joined
·
275 Posts
If it’s petrol or diesel a good half hour trip at 60-70 in 3rd gear should burn any crap out, if it doesn’t you’ll want to torch it after half a hour at 70 in 3rd gear as you’ll be sick of it, it does work sometimes, I did it in my old astravan 1.7 but I nearly torched it after 20 mins, stick with it though, it has worked!
 
1 - 4 of 4 Posts
Top