Vauxhall Corsa-D Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi everyone

I just brought a 2012 1.2 Limited Edition and i have noticed that the Cruise Control does not work.
I have also found that the Shift Up light does not come on even though the light works when turning the ignition on.

Does anyone have any suggestions to what could be the cause of these two issues please?

Thanks
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,404 Posts
I’d be thinking along the lines of the clutch position switch but it could be a older battery, unfortunately corsas are prone to little niggles if the battery isn’t 100% healthy, in any case you might need to think about having a diagnostic test run on it, a snap on, opcom or tech 2 reader, just to see if there’s any problems.
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,404 Posts
Fairly sure it won’t be the stalk itself as the other functions would be compromised, check the battery too, you want to do 4 tests, test battery as is, you want somewhere between 12.5 & 13.5 volts, 2 nd test, lights on and dash looking like a Christmas tree 2 nd position and 11.5 v minimum, 3rd test, lights off and start it, while running should be 12-14 v ish, 4 test lights, heater/ air con, rear window on de mist and radio on, 11.5-13.5 v. Anything drastically different it’ll be new battery time but by all means, get Halfords or the like to do a battery check beforehand. If you want to try clutch switch first use either Vauxhall bits or motor factors, just don’t trust Chinese internet parts as heard too many folks say I wish I’d got vaux bits to start with.
 

·
Registered
Joined
·
59 Posts
OpCom or Vauxcom can monitor the brake and clutch pedal switches along with each of the 3 stalk switches, which are all involved in the CC system.
Typically an out of adjustment clutch switch or a faulty brake pedal switch is usually the cause.
 
1 - 6 of 6 Posts
Top