Vauxhall Corsa-D Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So I have a 2011 Corsa Excite 1.2, the EML is on and I'm getting a code for the throttle position sensor 2, I've replaced the complete pedal assembly but still getting a fault, took it to another diagnostic garage and was told it's getting a high voltage at the pedal????
Really need this car fixed, it's driving me nuts. Any help or advice given would be fantastic, I'm wanting to sell it also so if anyone interested ...
Wheel Tire Car Automotive parking light Land vehicle
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I know 🙄 but was thinking everyone on here likes a Corsa so.............
On the plus side I've been honest with the fault and I'm wanting to fix it🤷
 

·
Registered
Joined
·
30 Posts
Have you the ability to check the voltages at the pedal. From experience a high voltage code is usually a missing 5v feed or missing earth and the ecu defaults to 5v which is why it logs a high voltage code as under normal working condition it would never see 5v unless there was a fault.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Have you the ability to check the voltages at the pedal. From experience a high voltage code is usually a missing 5v feed or missing earth and the ecu defaults to 5v which is why it logs a high voltage code as under normal working condition it would never see 5v unless there was a fault.
Thank you, any suggestions where to check for missing feed or earth? I mean is this a common fault on these? Thanks again. 😊
 

·
Registered
Joined
·
30 Posts
Do you have the exact fault code number

Id start at the pedal itself with a multimeter. You should have 2 x 5v, 2 x earth and 2 sensor return wires.
 
1 - 8 of 8 Posts
Top