Vauxhall Corsa-D Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all! I hope everyone is well!!
I’ve just bought a 2008 1.2 sxi corsa. It’s a beautiful vehicle.
While servicing it, I noticed that the engine bay is somewhat grimy and under the oil filter housing, there is some sort of sensor but it seems loose. Photo attached.
Automotive tire Motor vehicle Helmet Automotive design Rim

can someone advise me if this is meant to be secured in place with a clip or something?

Many thanks!!
 

Attachments

·
Super Moderator
Joined
·
1,355 Posts
This may help (video below)

If you are going to use mole grips to clamp the hose wrap some rag around the jaws so they don't cut the hose.

If you haven't done it before its best to have two people to bleed the clutch if you cannot get help you can get a special bleeder from Halfords that makes it a one-person job.

I don't know how he managed to get all the air out doing it that way.


Liquid Fluid Font Gas Auto part



 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks all!!! I’ll take it out for a spin tomorrow to see if it’s that what’s leaking or if it’s the oil filter housing as there seemed to be grime from that too! Many many thanks ❤
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Hi all - just a quick update on this one. It turns out that the oil filter housing was screwed on way too tight and had cracked. this caused oil to seep out of it and down over the clutch housing and the hose connection. When i degreased everything and replaced the housing, no more leaks or mess all over the place! Thank you everyone for your help though as i wasnt even sure what that hose was for!
 

·
Registered
Joined
·
1,269 Posts
Hi all - just a quick update on this one. It turns out that the oil filter housing was screwed on way too tight and had cracked. this caused oil to seep out of it and down over the clutch housing and the hose connection. When i degreased everything and replaced the housing, no more leaks or mess all over the place! Thank you everyone for your help though as i wasnt even sure what that hose was for!
Be sure to keep an eye on this, sometimes the build of grime can be from the seal on the gear selector shaft on top of the housing (near the gearbox oil fill plug) so give it a few weeks and check back

Sent from my moto g(8) plus using Tapatalk
 
1 - 9 of 9 Posts
Top