Vauxhall Corsa-D Forum banner

21 - 27 of 27 Posts

·
Registered
Joined
·
416 Posts
Yeah I think where I’m loosing oil is the coolant as the cap has some wierd substance in it, and I don’t think I’m burning any as I haven’t had any smoke or whichever? And I’m only loosing a couple notches every couple weeks, after heavy use tho
If the substance you are talking about on the coolant is WHITE, then that is just dried on coolant and is normal. If you ate looking oil mixing into the coolant it will be a horrible browny / creamy mayonnaise mixture in your coolant reservoir. This could be a sign of a head gasket leak. If your oil dipstick is dropping a few notches that would mean it burning about 1 litre of oil which is alot. So just be aware.

Sent from my SM-G935F using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #22
Thank you for the quick replies and the great advice! Think I might get some steel seal just incase as they is that weird browny substance but I don’t think the coolant has ever been cleaned before lol
 

·
Registered
Joined
·
416 Posts
Lol not a problem. If you want to give it a final last go, i would drain and flush the coolant (if you can change the oil you can do this - very easy + ive done it loads so csn help) you can find a video on youtube by Chris fix - how to flush your coolant. Gice the system a proper flush through and refill with new stuff. Then i woukd drain and flush your engine oil and refill with new (probably try a cheaper but good brand like triple qx on euro car parts to save on costs ). Then see how how your car runs, if the fresh coolant starts to get all brown oil in it, then most likely it clukd be a head gasket, which wont be worth the cost on that car and then you can try steele seal if you wish as it may get you a few.months to a year or so out of the car. But just try to bare in.mind the car.may not jave long so, maybe if you can try saving abit a.month for a new run around car.

Sent from my SM-G935F using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #24
Cheers buddy! I think because I caught it early and won’t be too big of a problem, I’m not sure whether to use steel seal or K seal?? Which one would you recommend? And should I flush my engine again did you say or just flush the coolant?
 

·
Registered
Joined
·
416 Posts
Cheers buddy! I think because I caught it early and won’t be too big of a problem, I’m not sure whether to use steel seal or K seal?? Which one would you recommend? And should I flush my engine again did you say or just flush the coolant?
I would flush both, the coolant and the oil, you can flush coolant by running water through it a few times but you can also buy some holts coolant flush. I wpuld go with steel seal, a guy i watched on youtube used for a customer and it seems to have work. BUT be sure to read the steel seal directions first as it may want you to flush things before or after etc, so do what ever that says first if it impacts on whether you should flush the oil and coolant or not.

Sent from my SM-G935F using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #26
Thank you for the great advice mate! Luckily I already bought some coolant flush so when I change my new centre pipe for my exhaust I’ll do a oil and coolant flush and make sure to follow the directions to a T!

cheers mate!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #27
I would flush both, the coolant and the oil, you can flush coolant by running water through it a few times but you can also buy some holts coolant flush. I wpuld go with steel seal, a guy i watched on youtube used for a customer and it seems to have work. BUT be sure to read the steel seal directions first as it may want you to flush things before or after etc, so do what ever that says first if it impacts on whether you should flush the oil and coolant or not.

Sent from my SM-G935F using Tapatalk



Hiya mate I need your help, so I went down to my dads who used to be a mechanic so he could change my centre pipe and do the other stuff. And it's a good job I did change that pipe as it had a massive hole in and was just rusted so much, and the o2 sensor was literally stuck in it was like it was welded but we managed to get it off as my dad had a bit that helped make it more secure. After changing the centre pipe and doing a engine flush with new oil and filter, then a coolant flush with the steel seal. Everything seemed perfect until the engine management light came on now my car sounded so much better and healthy but this light was on which was weird but no oil pressure light or anything so got rid of that. My dad had an OBD2 reader and read the codes which came us as P0036 and P0141 which is H2OS bank sensor or somert?? Please can you help me with this, I am not sure what to do, the car drives and performs so much better.
 
21 - 27 of 27 Posts
Top