Vauxhall Corsa-D Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
I looked into this for a while and there was no information on here so I found it elsewhere. If you have a basic model such as life with no steering wheel controls, yet you fit a steering wheel with the controls and then have them Tech 2'd they work but in most cases they wont illuminate, this is because there's a missing illumination wire (there will also be a fault code stating that a circuit is open).
The wire is simple to fit it runs from the steering wheel module (the large connector at the bottom on the back)
As shown in the picture remove the inner slide and add the wire to Pin 7 (the wire colour is supposed to be yellow/grey as in the picture but doesn't really matter)
then refit the connector and then wire the other end of the wire into a illumination wire in the car (can be any such as centre console, light switch, cigarette lighter illumination, e.t.c..)
IMG_1101.jpg

Then enjoy illuminating steering wheel controls :D
 

Attachments

·
Registered
Joined
·
2 Posts
Newbie finding CDUK great help..

Just about to have a go at Fitting CD30 MP3 for AUX, Steering wheel Upgrade for wheel controls... then a Sub/Amp and Hopefully
Thanks for Info, but whats Tech2?.
 

·
Registered
Joined
·
2 Posts
Ahh right get that now! who's good in south wales for Tech 2?... is it expensive? I Got Aux running earlier :biggrin:, SXI Steering wheel with buttons coming this weekend so plan to do that next,will the Corsa life have the correct cables/connections ready to connect to that?
Thanks for the help and info so far.
 

·
Registered
Joined
·
48 Posts
am i just being dumb or .... i couldent really locate that connector? when i changed my steering wheel to one with controlers
 

·
Registered
Joined
·
1 Posts
Just one question guys. I retrofitted steering wheel with controls on my Corsa D and fitted the missing illumination wire.
The controls are still not yet activated with Tech2, and they just barely light up at the moment (only one button at each side).

Will this issue that bothers me fix itself when I activate them via Tech2?
 
1 - 12 of 12 Posts
Top