Vauxhall Corsa-D Forum banner

41 - 51 of 51 Posts

·
Registered
Joined
·
76 Posts
i understand what they asked. Apparently if everithing is ok on the small display (that shows temperature and time) i should be able to read information about radio station and music.
But that's not what's happening. Ever since i connected radio i have a "display safe" message and clock is not ritght (in time). Could be this be any indication of problem?
It's only for example purpases but my display is like so...

View attachment 20168

Ever happened to anyone??
For aftermarket head units it usually happens. Sometimes the whole unit won’t power up or some other issues might occur. That’s probably a factor of the controls not working.

Try leaving the car battery off to let it all reset, and seeing if it fixes. If not then do the same but connect your old VX unit to get rid of the Display safe
 

·
Registered
Joined
·
16 Posts
well that's going to be a problem e don't have original radio i have sell it! but i will try battery trick! when it's working it displays for example song name or radio station on display
 

·
Registered
Joined
·
107 Posts
It means the radio is not linked to the display. This should only occur on genuine Vauxhall steros if the display and the radio are not from the same car or have not been linked.

I would think it suggests an issue with the canbus box myself as it seems like there is a communication issue.
 

·
Registered
Joined
·
16 Posts
Yes i think so too but this appears ever since radios was installed . Even if i disconnect canbox message remains... lets see what they say
 

·
Registered
Joined
·
76 Posts
Yes i think so too but this appears ever since radios was installed . Even if i disconnect canbox message remains... lets see what they say
Sounds like a faulty canbus box, get back to them and tell them it doesn't work as expected. It shouldn't display safe and it indicates an error with the canbus box, plus the steering controls not working. They should send you a new canbus box if it's still in warranty.
 

·
Registered
Joined
·
76 Posts
As i wrote a few days ago they have exchange canbox, same thing happens, so not canbox problem it seems
I'm pretty sure the fault can only be either with the car or the canbus box. The head unit itself only take's commands from the Canbus Box. Either it's an issue from the Car not sending info to the box (which may be related to the Display Safe issue), or it's an issue with the box not being able to process the info.

If the message is stuck on the screen even after a battery reset then you may be stuck if you don't have the original head unit to clear the message off. Though according to other posts, if the battery is out for 10 mins then it should clear the message.
 

·
Premium Member
Joined
·
400 Posts
Think because the original radio has been taken out and a new one installed that has can bus on it it could be the fact the original radio that worked with the display hasn’t been divorced, in effect the car/ display thinks it’s been stolen so even if there was a standard radio put in it’ll still show display safe. I wonder if because new one is canbus ready the car is recognising it as a new stereo that’s not paired to the display. I take it you still have the radio card with the code on?
 

·
Registered
Joined
·
16 Posts
I have sell original radio. Even so its not the message that upset me i am more concern about steer wheeel controls not working. Going try the battery tip to see what happens.
Even so i am almost sure that wont solve the problem of canbus even if it clears error display message
 

·
Registered
Joined
·
107 Posts
I have sell original radio. Even so its not the message that upset me i am more concern about steer wheeel controls not working. Going try the battery tip to see what happens.
Even so i am almost sure that wont solve the problem of canbus even if it clears error display message
I don't think there's anything more we can suggest.

All you can do is try our suggestions, or contact the manufacturer or use a third party steering adaptor.

Sent from my CPH1921 using Tapatalk
 

·
Registered
Joined
·
16 Posts
Hello there... just want you guys now that for whatever reason my problem is solved. I have steering wheel control at this moment.

Out of the blue i started my car as usual and noticed that message on small display screen "display safe" had disapeared and instead i can see what radio station my radio was...

Also buttons on front panel of radio got light, witch didn't happen before! And i then tried buttons on steer and they work, i can change volume, rado station and so on!

I'am still not sure what the hell happened but all of a sudden, things started to work!
 
41 - 51 of 51 Posts
Top