Vauxhall Corsa-D Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
hi i have a corsa d with a z1.2 xep engine that snapped its cam chain last week, i stripped every thing off head ect expecting to find some valve damage or piston damage but every thing seem to be fine. All the valves are seated and if i turn the cams over with a spanner they open and close fine so don't think they have hit the pistons. the pistons , head gasket ect are all fine and moving up and down if i turn the engine crank shafti have done a leak test on the seats filling with carb cleaner and i have a very small leak on 1 exhaust valve by small i mean vapor showing after sitting for 2 hours. i was planning to lap the valves any way as i expected to need some new ones. every one says that its very unlikely to have zero damage when a chain snaps while engine is running has an one any ideas of any thing else to test/try or would you guys just get a head/timing chain kit and rebuild it. any advice would be apricated
 

·
Registered
Joined
·
82 Posts
I cannot answer the question but have a couple if you don't mind answering as this is something i rarely see.

How old is the car?

How many miles has it done?

Did you get any warning signs (noises etc) before it broke?

Was the oil and filter regularly changed?

How long have you owned it?

Did it have any service history when you bought it?
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,064 Posts
You might have been extremely lucky and not damaged anything major, all I can suggest is rebuild and keep your fingers crossed, if you’ve got away with it buy a lottery ticket!
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
I cannot answer the question but have a couple if you don't mind answering as this is something i rarely see.

How old is the car?

How many miles has it done?

Did you get any warning signs (noises etc) before it broke?

Was the oil and filter regularly changed?

How long have you owned it?

Did it have any service history when you bought it?
09 plate has only done 45000 ish miles. did have a bit noise on tick over but ran great and yes oil, filters regularly done i have had the car from it been 7 month old . car was fine was out in it and it just cut out at a junction
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
You might have been extremely lucky and not damaged anything major, all I can suggest is rebuild and keep your fingers crossed, if you’ve got away with it buy a lottery ticket!
You might have been extremely lucky and not damaged anything major, all I can suggest is rebuild and keep your fingers crossed, if you’ve got away with it buy a lottery ticket!
thats what i plan to do just keep thinking have i missed some thing . did find 2 hydraulic lifters that have came apart
 

·
Registered
Joined
·
82 Posts
Thanks, sounds like you have been very unlucky as snapped chains are not something you read about often.
 

·
Registered
Joined
·
859 Posts
hi i have a corsa d with a z1.2 xep engine that snapped its cam chain last week, i stripped every thing off head ect expecting to find some valve damage or piston damage but every thing seem to be fine. All the valves are seated and if i turn the cams over with a spanner they open and close fine so don't think they have hit the pistons. the pistons , head gasket ect are all fine and moving up and down if i turn the engine crank shafti have done a leak test on the seats filling with carb cleaner and i have a very small leak on 1 exhaust valve by small i mean vapor showing after sitting for 2 hours. i was planning to lap the valves any way as i expected to need some new ones. every one says that its very unlikely to have zero damage when a chain snaps while engine is running has an one any ideas of any thing else to test/try or would you guys just get a head/timing chain kit and rebuild it. any advice would be apricated
Yeah seems you may have gotten lucky, I would probably change lifts and put a.new gasket on and then timing chain kit and see how you get on.

Sent from my moto g(8) plus using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Yeah seems you may have gotten lucky, I would probably change lifts and put a.new gasket on and then timing chain kit and see how you get on.

Sent from my moto g(8) plus using Tapatalk
thanks i was going to just replace the 2 lifters as the others can be done after the rebuild if the engine is noisy but actually starts. This is because of cost as you need the head bolts as well as gasket because the bolts stretch so it comes as a kit with the chain ect and about £100 plus for a good quality one
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Thanks, sounds like you have been very unlucky as snapped chains are not something you read about often.
np yes i have noticed they seem to get changed because of stretching not snapping, wish mine had stretched would of been a lot less work and not be wondering if it will run after i rebuild it
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,064 Posts
After 15 months of COVID-19 and that strange orangey hot thing in the sky been seen for longer than 2 minutes I’ll put it down to fear, fear of something big happening, something unusual, something often talked about yet rarely seen, yep a decent summer! I must get out of the direct sunlight, I’m going boo loo! 😂
 
1 - 12 of 12 Posts
Top