Vauxhall Corsa-D Forum banner
1 - 8 of 8 Posts

·
Registered
2012 Corsa D CDTi EcoFlex 1.3l 75hp Diesel
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all,

Recently had my egr valve on my 1.3 2012 CDTi EcoFlex 75hp changed and a new radiator fitted. This made the engine light which was on all the time beforehand switch off.

Next day, the service spanner light came on whilst driving. Plugged in the fault code reader and no faults were found. Car also drove as normal.

Any ideas as to why this may be happening?
 

·
Registered
2012 Corsa D CDTi EcoFlex 1.3l 75hp Diesel
Joined
·
7 Posts
Discussion Starter · #3 ·
I thought it would be more appropriate seeing as the EGR has been replaced and the DPF has successfully regened. Plus it means individuals who have experience or are familiar with this specific issue will be able to find my thread straight away as it is summarised within the title. Thank you for your comment
 

·
Registered
Joined
·
221 Posts
Good luck getting help, i still think something dodgy has gone on with the EGR you discussed in the other thread and this is giving you more problems.
 

·
Registered
Joined
·
933 Posts
Hi all,

Recently had my egr valve on my 1.3 2012 CDTi EcoFlex 75hp changed and a new radiator fitted. This made the engine light which was on all the time beforehand switch off.

Next day, the service spanner light came on whilst driving. Plugged in the fault code reader and no faults were found. Car also drove as normal.

Any ideas as to why this may be happening?
You mention you have a spanner light but no codes are showing. Are you using a very basic scan tool? If so you will need to get it scanned by a garage who can tell you what it is showing. It could be something different. But double check the egr connection plug as.it.could be.something simple also

Sent from my moto g(8) plus using Tapatalk
 

·
Registered
2012 Corsa D CDTi EcoFlex 1.3l 75hp Diesel
Joined
·
7 Posts
Discussion Starter · #6 ·
Took to Kwik Fit, glow plug 4 is faulty. Not in a rush to change it.
 

·
Registered
Joined
·
933 Posts
Took to Kwik Fit, glow plug 4 is faulty. Not in a rush to change it.
Well just be careful as it could cause starting issues if left too long. Glows plug not to bad to change,just be sure to by some.plus gas spray and soak it for 3 days , day and night.

Sent from my moto g(8) plus using Tapatalk
 

·
Premium Member
2012 sxi 1.2 5 door in black
Joined
·
1,245 Posts
Right I’ll see your sod of a plug change on the corsa and raise you a 1988 vw caddy 1.6 diesel , plug 4 is a strip the whole vehicle down to get to it, think getting in and out of it at 6 ft 3 with the steering wheel, literally in your nuts, it only gets more difficult/painful if you chub up! 🤒 🤕
 
1 - 8 of 8 Posts
Top