Vauxhall Corsa-D Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey new to this forum. Ive had my Corsa for about 1 year, its a 2014 plate 58k miles. Ever since I've had it there has been a problem with the steering. On a straight road it pulls to the left and the steering is not straight and its driving me crazy !

Ive had top mounts, struts, drop-link's inner and outer tie rods replaced and still have this issue and have had 5 alignments. The tyres are more worn on the inside then the outside (Front) wonder if this is causing the issue.

I really want to fix this or else I want to get rid of the car, any suggestions would be helpful please.

ps Im only a student so don't have lots of money to try other possible solutions that don't work.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Hey new to this forum. Ive had my Corsa for about 1 year, its a 2014 plate 58k miles. Ever since I've had it there has been a problem with the steering. On a straight road it pulls to the left and the steering is not straight and its driving me crazy !

Ive had top mounts, struts, drop-link's inner and outer tie rods replaced and still have this issue and have had 5 alignments. The tyres are more worn on the inside then the outside (Front) wonder if this is causing the issue.

I really want to fix this or else I want to get rid of the car, any suggestions would be helpful please.

ps Im only a student so don't have lots of money to try other possible solutions that don't work.
Also in the MOT recently they noted that the left lower control arm bushing had cracks in it, I don't know if this affects anything.
 

·
Registered
Joined
·
768 Posts
Hey new to this forum. Ive had my Corsa for about 1 year, its a 2014 plate 58k miles. Ever since I've had it there has been a problem with the steering. On a straight road it pulls to the left and the steering is not straight and its driving me crazy !

Ive had top mounts, struts, drop-link's inner and outer tie rods replaced and still have this issue and have had 5 alignments. The tyres are more worn on the inside then the outside (Front) wonder if this is causing the issue.

I really want to fix this or else I want to get rid of the car, any suggestions would be helpful please.

ps Im only a student so don't have lots of money to try other possible solutions that don't work.
Hey seems like you have had slot done,

Not sure how DIY you are but there is a few things to try.

1) You tyre wear could be causing it, have you check your tyres pressures? Make sure they are correct and not underinflated

2) If you can raise the vehicle, move the front tyres to the back and back tyres to the front, if it goes awhile for a.good while road trip wise you know it's the tyres.

2) The ball joint could be an issue but only if it's excessive, again this is something you could do with supporting the car on axle stands, holding the front wheels, and shake them up and down and left to right, if there.is.alot of.play then it is a bad wheel bearing or ball joint.

3) Have a look by turnin the wheels left and right and with a torch and it on the ground as normal and see if any loose bolts, on the shock absorber hub bolts , drop links aka anti roll ball , or ball joint s.

4) Was the car ever in an accident as it could be something is slightly bent or out, which it would be just live wallpaper th it as trying to find it maybe hard if it not obvious to the eye.

Sent from my moto g(8) plus using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Hey seems like you have had slot done,

Not sure how DIY you are but there is a few things to try.

1) You tyre wear could be causing it, have you check your tyres pressures? Make sure they are correct and not underinflated

2) If you can raise the vehicle, move the front tyres to the back and back tyres to the front, if it goes awhile for a.good while road trip wise you know it's the tyres.

2) The ball joint could be an issue but only if it's excessive, again this is something you could do with supporting the car on axle stands, holding the front wheels, and shake them up and down and left to right, if there.is.alot of.play then it is a bad wheel bearing or ball joint.

3) Have a look by turnin the wheels left and right and with a torch and it on the ground as normal and see if any loose bolts, on the shock absorber hub bolts , drop links aka anti roll ball , or ball joint s.

4) Was the car ever in an accident as it could be something is slightly bent or out, which it would be just live wallpaper th it as trying to find it maybe hard if it not obvious to the eye.

Sent from my moto g(8) plus using Tapatalk
hey, yeah I made sure all the tyre pressures are all correct, so it’s not that. Hoping it’s the tyre wear that’s causing it and not anything else that I need to replace. I’m going to try you suggestion of moving the tyres front to back hopefully this will help.

Could it be possible for the lower ball joint to wear out in 58K miles ?

Thank you for your help, will try and jack the car up.
 

·
Registered
Joined
·
768 Posts
Yes a bad ball joint could be the issue. But you need check it prooerly. Well actually since it came up in an advisory I would change them anyway becuas eit going to fail at some point, but check it first , but sometimes a bad one doesn't always show clearly ( watch video that see what I mean :
). But it being on MOT I would do it because it just looks good that you took car of it in the future if you decide to sell car.

Sent from my moto g(8) plus using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Yes a bad ball joint could be the issue. But you need check it prooerly. Well actually since it came up in an advisory I would change them anyway becuas eit going to fail at some point, but check it first , but sometimes a bad one doesn't always show clearly ( watch video that see what I mean :
). But it being on MOT I would do it because it just looks good that you took car of it in the future if you decide to sell car.

Sent from my moto g(8) plus using Tapatalk
Okay that video clears it up ! Thank you !
 

·
Registered
2008 SRI-Turbo
Joined
·
197 Posts
Does it consistently pull to the left, what are the roads like?
Sometimes roads with severe camber can cause uneven tire wear and will have a tenancy to pull the car towards the verge.
 

·
Registered
Joined
·
94 Posts
First things first, you need to bring the car to a tyre fitter and get the tracking done on the front two wheels. This is not expensive to do and is more than likely the cause of the car pulling off centre and the excessive tyre wear.
 
1 - 9 of 9 Posts
Top