Vauxhall Corsa-D Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #1
Been having a vibration a low RPM for ages now. I've replaced the clutch, flywheel, CSC, uprated gearbox, exhaust, fuel pump and taken out all intake mods which may cause vibrations but it's still doing it. Literally at my last nerve with the thing now. It only does it when the engine is at operating temp and when at low revs applying load to the engine. It's just a vibration coming from the engine bay. Car drives and runs perfectly. Car is a 1.7 CDTi (2011).

Ta
 

·
Registered
Joined
·
169 Posts
Discussion Starter #4
I'm as happy as a pig in ****!! Spent way over £2k to get rid of it. Things that got replaced needed replacing anyway but could have waited a few more months. But hey ho, live and learn.
 

·
Registered
Joined
·
436 Posts
I'm as happy as a pig in ****!! Spent way over £2k to get rid of it. Things that got replaced needed replacing anyway but could have waited a few more months. But hey ho, live and learn.
Lol, you do live and learn, the curse of being DIY always think it's big but could be small. But everything is taken car of now, car all happy.

Sent from my moto g(8) plus using Tapatalk
 

·
Registered
Joined
·
169 Posts
Discussion Starter #6
Yep for now. No doubt something will go wrong soon. Always has moments of it running perfectly then boom, something goes wrong. Luckily all the big expensive jobs have been taken care of. Just fingers crossed the engine internals stay happy else all that money down the drain.
 
1 - 6 of 6 Posts
Top