Vauxhall Corsa-D Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi folks,
Anyone know what could be the issue with my 2009 1.2 petrol sxi corsa?
Recently swapped back to factory airfilter from a Ramair air cone.
The cold intake pipe is not yet fitted as Im still waiting for parts.
Noticed a slight hesitation when reving up in 2nd gear, rest of the gears are fine.

Spark plugs been changed in March 2022.

 

·
Registered
Joined
·
38 Posts
Hi folks,
Anyone know what could be the issue with my 2009 1.2 petrol sxi corsa?
Recently swapped back to factory airfilter from a Ramair air cone.
The cold intake pipe is not yet fitted as Im still waiting for parts.
Noticed a slight hesitation when reving up in 2nd gear, rest of the gears are fine.

Spark plugs been changed in March 2022.

If its happening when the engine is warm then it would be getting too much hot air instead of the Cold air it needs.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Did you leave the lower part of the air filter box in place with the original cold air feed, also could try adding another cold air feed pipe. Do you get any weird rattle sound when accelerating in second?
Hi Bishmyster,

I had to buy a cold air feed pipe as i bought the car with a performance airfilter installed.
I have checked now the pipe and its a bit loose where it connect to the airfilter box.
Also, i have a slight rattle on second gear just.
See the video.
 

·
Registered
Joined
·
38 Posts
Hi Bishmyster,

I had to buy a cold air feed pipe as i bought the car with a performance airfilter installed.
I have checked now the pipe and its a bit loose where it connect to the airfilter box.
Also, i have a slight rattle on second gear just.
See the video.
Video is private, It's odd that i had a slight rattle with low rev's in 1st-2nd after id fitted my RamAir Pro Filter, the rattle you couldn't hear in the higher rev range. Got a friend who owns a garage locally to take a look for me in a couple of weeks as i am extremally busy over the next few weeks and he suspects the same as i do that its the heat shield and/or the exhaust support bracket near the front of the car that one of two bolts has snapped.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Video is private, It's odd that i had a slight rattle with low rev's in 1st-2nd after id fitted my RamAir Pro Filter, the rattle you couldn't hear in the higher rev range. Got a friend who owns a garage locally to take a look for me in a couple of weeks as i am extremally busy over the next few weeks and he suspects the same as i do that its the heat shield and/or the exhaust support bracket near the front of the car that one of two bolts has snapped.
Hi Bishmyster,

I have changed the privacy on the video.

Cheers for tips,I will check them over the weekend!
 

·
Registered
Joined
·
38 Posts
Hi Bishmyster,

I have changed the privacy on the video.

Cheers for tips,I will check them over the weekend!
The sound from the exhaust i am unsure about, mines had a decat, and a bigger bore exhaust. Now onto the slight hesitation you was on about, when was the last time it has had new spark plugs ? I have changed the spark plugs on mine and have stopped noticing the hesitation up to now(Fingers crossed). the ones i took out looked like they'd been in a while.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
The sound from the exhaust i am unsure about, mines had a decat, and a bigger bore exhaust. Now onto the slight hesitation you was on about, when was the last time it has had new spark plugs ? I have changed the spark plugs on mine and have stopped noticing the hesitation up to now(Fingers crossed). the ones i took out looked like they'd been in a while.
Hi Bishmyster,

They have been changed in March so roughly 6 months ago. Not sure if you picked up from the video but the intake pipe is a bit loose, maybe that could be the culprit or someone advised me to replace the coil pack as it quite common issue with Corsa`s.
 

·
Registered
Joined
·
38 Posts
Hi Bishmyster,

They have been changed in March so roughly 6 months ago. Not sure if you picked up from the video but the intake pipe is a bit loose, maybe that could be the culprit or someone advised me to replace the coil pack as it quite common issue with Corsa`s.
The cold air intake pipes are generally loose to a degree, due to the way air is forced in there's generally enough air always forced in the box. It is possible logically that if too much air escaped, along with the car being at a low speed in 2nd gear that maybe there could be a fraction to little of cold air available.

If the cold air pipe wont tighten enough to give a perfect seal you could try making a seal, id personally use something like a bike inner tube cut to size then tie wrapped over. Or any other way possible to seal it.

It does come down to either Spark or Fuel and/or Air that causes the issue, it may be a case of elimination. Another thing id suggest if you're not already doing is to use E5 fuel and not E10.
The ECU should mess with the fuel-air ratios to get the best stoichiometry(Mixture) but this does not always result in the ideal mixture.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
The cold air intake pipes are generally loose to a degree, due to the way air is forced in there's generally enough air always forced in the box. It is possible logically that if too much air escaped, along with the car being at a low speed in 2nd gear that maybe there could be a fraction to little of cold air available.

If the cold air pipe wont tighten enough to give a perfect seal you could try making a seal, id personally use something like a bike inner tube cut to size then tie wrapped over. Or any other way possible to seal it.

It does come down to either Spark or Fuel and/or Air that causes the issue, it may be a case of elimination. Another thing id suggest if you're not already doing is to use E5 fuel and not E10.
The ECU should mess with the fuel-air ratios to get the best stoichiometry(Mixture) but this does not always result in the ideal mixture.
Hi bishmyster,

Thanks for the tip. I will check re-check the sparkplugs and will fill up with E5. I will let you know how it goes.
 
1 - 12 of 12 Posts
Top