Vauxhall Corsa-D Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
422 Posts
Discussion Starter #1
Hey guys.

Have a Vauxhall Corsa D. I'm assuming due to bad weather it has coursed this. But when I turn on my wipers I can here a terrible rattle from inside the car. I pushed.down on them and one is solid and the other has a lot of play. Does anyone know how to fix this. (Link to the video of it happning below)

Thanks any help would appreciate it

https://youtu.be/Ruw6kj8Q5m8


Sent from my SM-G900F using Tapatalk
 

·
Registered
Joined
·
516 Posts
^ it won't be that, that just tightens the wiper arm onto the linkage spindle.

Its difficult to tell from the video but i'd say either;

a) the wiper linkage has detached itself from its mountings
or
b) the wiper linkage itself has broke (i've read about this over on VXRO but not experienced it myself).

I think you need to take the plastic cowl off under the wiper arms and have a good look at the linkage to be sure.

Unfortunately this will mean removing the wiper arms which is a PITA;
- Prise of the small plastic cap,
- Undo the 13 (iirc) nuts.
- Remove each wiper arm

Depending how old the car is the wiper arm can put up a struggle...sometimes they'll pull off the spindle with a good tug, but if you're really unlucky you'll need to buy a wiper arm puller to separate them.

Do not be tempted to wedge anything between the arm and windscreen for leverage as you stand a good chance of cracking your windscreen!

Once the arms are off the plastic cowl just unscrews (3 screws iirc) and pulls off.

From there you can inspect the linkage...its held on with 2 torx bolts...with a bit of luck one has come loose and needs tightened/replaced.

If not it might need a replacement linkage.

Should be obvious with the cowl off tho
 

·
Registered
Joined
·
516 Posts
Actually if just you undo the screws holding the cowl on you might be able to lift it up enough to see the mounting screws without taking the wipers off i think
 

·
Registered
Joined
·
422 Posts
Discussion Starter #5
^ it won't be that, that just tightens the wiper arm onto the linkage spindle.

Its difficult to tell from the video but i'd say either;

a) the wiper linkage has detached itself from its mountings
or
b) the wiper linkage itself has broke (i've read about this over on VXRO but not experienced it myself).

I think you need to take the plastic cowl off under the wiper arms and have a good look at the linkage to be sure.

Unfortunately this will mean removing the wiper arms which is a PITA;
- Prise of the small plastic cap,
- Undo the 13 (iirc) nuts.
- Remove each wiper arm

Depending how old the car is the wiper arm can put up a struggle...sometimes they'll pull off the spindle with a good tug, but if you're really unlucky you'll need to buy a wiper arm puller to separate them.

Do not be tempted to wedge anything between the arm and windscreen for leverage as you stand a good chance of cracking your windscreen!

Once the arms are off the plastic cowl just unscrews (3 screws iirc) and pulls off.

From there you can inspect the linkage...its held on with 2 torx bolts...with a bit of luck one has come loose and needs tightened/replaced.

If not it might need a replacement linkage.

Should be obvious with the cowl off tho
Hey U33. Thanks for the input bro. I'll have a look. Is it ok to leave for a few weeks as this weather I can barely be outside for 5 mins let alone working on a car amount of time. Or is get it fixed asap as my blade us just hanging on?

Sent from my SM-G900F using Tapatalk
 

·
Registered
Joined
·
516 Posts
Yeah you don't need to tell me about the weather - i spent saturday out in -5 temps trying to fit a sports cat to my SRI.

Its a rotten time to be working on cars!

As for your wipers i dunno; i only drive about 30 miles a day back and forward to work so barely use my wipers...if i was doing mega miles per day i'd want to fix it sooner rather than later.

What i mean is i don't think yours is about to fall off and damage anything else if you leave it a week or so.
 

·
Registered
Joined
·
422 Posts
Discussion Starter #7
Yeah you don't need to tell me about the weather - i spent saturday out in -5 temps trying to fit a sports cat to my SRI.

Its a rotten time to be working on cars!

As for your wipers i dunno; i only drive about 30 miles a day back and forward to work so barely use my wipers...if i was doing mega miles per day i'd want to fix it sooner rather than later.

What i mean is i don't think yours is about to fall off and damage anything else if you leave it a week or so.
Thanks again u33. I'll have a look weekend and try just lift the cowl up and get a video of what's going on or worse case.remove it all. But should be able to give you a better idea if what's what's

Sent from my SM-G900F using Tapatalk
 
1 - 7 of 7 Posts
Top